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Introduction to SITS:Vision Client Server 
 

- Foundation / basic skills course - 
 

 

Course Description. 
 

This course is designed to provide an introduction to the 

SITS:Vision client server  software.  A range of navigation 

methods and examples of useful tools will be outlined to 

provide the user with a practical introduction to SITS:Vision. 
 

It should be noted that the topics presented during this course 

are designed to provide a foundation for further SITS:Vision 

training and should be considered preparatory to all other 

SITS:Vision courses. 
 

Objectives. 
 

During this course, you will learn many aspects of the SITS:Vision client server including: 
 

 Introduction to SITS:Vision 

 Differences between SITS:Vision client server and e:Vision 

 Examples of client server and e:Vision screens 

 Logging into and out of SITS:Vision client server 

 Windows tree style menus and the panel buttons 

 Using commands to display tables/screens 

 SITS:Vision client server screen components 

 Further navigation and shortcuts 

 Record operations: 

o Retrieving, adding, deleting & releasing records 

o Using first, previous, next or last record navigation icons 

o Wildcards and Boolean operators 

 Tools: 

o Special characters 

o GoTo field contents 

o Sorting 

o Dropping records 

o Quick analysis 

o Cross referencing analysis 

o Exporting quick analysis or cross referencing analysis data. 
 

Pre-requisites. 
 

Any introductory knowledge of using the computer in a Windows 

environment will be an advantage although no specialised knowledge of 

SITS:Vision or the client server software is necessary.  This course will 

present a basic introduction to SITS:Vision client server including 

navigational topics and a range of tools. 
 

Manual Version 1.2 
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Notations 
 

The following notations and terms will be used during the course: 

 
  

 

 

 

 

 

 
 Keyboard Shortcuts:  

 

- i.e. CTRL+Q  (hold down the CTRL key and press Q) 

 

 Menu Items: 
 

- i.e. File, Exit  
 

(select the File menu and choose the Quit command or use ALT+F and 

then ALT+Q). 

 

 Mouse operations 
 

Select, click or left click: Click the left button on the mouse. 

 

Double click: Click the left mouse button (primary button) in two quick 

successive clicks. 

 

Right click: Click the right mouse button (secondary button) over an area 

on the screen to display a context/pop-up menu (the menu 

will show a range of suitable commands). 

 

Please note that if your mouse configuration is set to ‘left handed mode’ (instead 

of ‘right handed mode’) the buttons will be reversed.  In ‘left handed mode’, the 

right-most button will be set as the primary button (for single or double clicking) 

and the left-most button will be set as the secondary button (i.e. for ‘right click’ 

operations where a context/pop-up menu will be displayed). 

 

This course has been designed for users of Windows XP.  The screenshots 

presented throughout this manual will therefore apply windows, icons, screens 

and buttons based on the default Windows XP style. 
 

 

 

Disclaimer 

 

The training materials provided in this manual have been created 

by the University of London for staff/users of SITS:Vision and 

e:Vision.  Please note that the training materials are not sourced or 

supported by Tribal Group plc. 

 

 

Exercise example to work through. 

Hints, tips and highlighted information. 
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Section 1 – Introduction to SITS:Vision 

 
In this section of the course, you will learn about: 

 

 

 Introduction to the SITS:Vision system 

 

 

 

 

 Differences between SITS:Vision client server and e:Vision 

 

 

 

 

 Examples of client server and e:Vision screens. 

 

 

 

 

 Loading SITS:Vision 

 

 

 

 Logging into SITS:Vision 

 

 

 

 Closing and logging out of SITS:Vision 

 

 

 

 

 

 

 

 

 

 

There is one exercise in this section to help illustrate the above topics: 

 

 Exercise 1A: Loading the SITS:Vision client server software, logging in and closing. 
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1.0 Introduction to SITS:Vision 
 

SITS:Vision (also known as SITS), is a management information system used by many 

Higher Education institutions across the UK.  The SITS:Vision software is supplied by the 

company Tribal.  The name ‘SITS’ was originally derived from ‘Strategic Information 

Technology Services’ who joined Tribal Group plc in October 2004. 
 

SITS:Vision supports the administration of students and courses within universities and 

colleges. It is designed to increase efficiency in administrative processes by way of highly 

functional software working in conjunction with innovative technologies such as automation 

and workflow management. 
 

The software is designed to assist with statutory reporting and the production of flexible 

reports using key data. SITS:Vision provides a powerful and reliable database as well as 

flexible and efficient software to manage the unique needs of higher education. 
 

There are two sides of SITS:Vision that you will use: 
 

 SITS:Vision client server 
 

 e:Vision
1
 

 

SITS:Vision client server provides a ‘back end’ to the system and is useful for infrequent 

tasks.  SITS:Vision client server cannot be modified with regards to the appearance of 

various screens.   
 

e:Vision provides secure portal access via the web and is used to manage the delivery of data 

and information from the SITS:Vision client server software.  The e:Vision portal is useful 

for frequent activities as screens are customised to obtain/store the required information. 

 

Further details with regards to the differences between SITS:Vision client server and e:Vision 

are presented in the next section of the course. 

 

 

 

SITS:Vision High-Level Table Hierarchy 
 

The diagram shown right presents a 

simplified introduction to the hierarchy of 

records and the main aspects of the student 

lifecycle in SITS:Vision (without the 

processing screens). 

 

The MST (Master) table holds the person 

information and the related tables show 

examples of the roles that a person can 

have. 

 

 

                                                 
1
 e:Vision provides secure portal access via the web and is used to manage the delivery of data and information 

from the SITS:Vision client server system. 
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1.1 Differences between SITS:Vision client server and e:Vision  
 

The client server software is provided in an ‘as is’ or ‘out of the 

box’ manner in much the same way as most ‘off the shelf’ 

software systems.   

 

For example, when you install and use an application such as Microsoft Word – this is 

provided in an ‘as is’ or ‘out of the box’ fashion.  Most (if not all) of the screens are already 

created and arranged by the software developer/company.  A range of predetermined 

icons/menus/tools/dialogs are also provided. 

 

With regards to SITS:Vision client server, a range of useful tables/screens and processes are 

already provided by the software so that it can indeed be used in an ‘out of the box’ manner.   

 

SITS:Vision client server cannot be modified with regards to the appearance of various 

screens.  However, not all of the fields in each table/screen need to be necessarily used as 

only the desired fields may be utilised as required.  Additional fields may also be added to 

existing screens (in the form of ‘user defined fields’). 

 

 

E:Vision provides secure portal access via the web and is used 

to manage the delivery of data and information from the 

SITS:Vision client server software.   

 

Tables/screens can be fully customised (unlike the tables/screens in client server) so that only 

the required elements are displayed to a user.  Branding can also be applied to e:Vision 

screens with regards to colours, logos etc.   It should be noted however that not all client 

server tables/screens or processes can be represented in e:Vision.   

 

E:Vision is useful for frequent activities as the tables/screens are customised to obtain/store 

the required information in the most efficient manner available.  Data entry in an e:Vision 

screen can also be optimised (for example, when pressing the TAB key to move to another 

field, the order in which the cursor moves to another field can be arranged to enhance the 

flow of navigation). 

 

Users of SITS:Vision are often advised that the client server can be used for infrequent tasks 

(i.e. once-a-day processes for example) or that the client server can be thought of as a 

‘back end’ to SITS:Vision.  E:Vision can therefore be thought of as a ‘front end’ for users. 

 

 

 

 

 

 

 

 

 

 

 

 

SITS:Vision  
client server 

 
- Think of as a ‘back end’. 
- Useful for infrequent activities. 
- Tables/screens cannot be 

modified. 

e:Vision 
 

- Web-based ‘front end’. 
- Useful for frequent activities. 
- Tables/screens can be 

customised and branded. 

 

Client Server 
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1.2 Examples of client server and e:Vision screens 
 

As an example of the difference between SITS:Vision client server and e:Vision screens, the 

screenshots in this section illustrate how information with regards to an Enquirer would be 

displayed to a user.  
 

 

1.2.1 Client server example screens 
 

In this example, the Enquirer Student Detail (ESD) table/screen will be presented to 

illustrate a typical screen in the SITS:Vision client server software. 

 

To load the ESD table (for this 

example), enter ESD into the 

option box and select the Run 

button, press the TAB key or 

press the ENTER key on the 

number pad.  
 

 

Alternatively, locate the ESD screen in the following menus: Admissions (MAS), Enquiry 

Process Menu, Enquirer Data. 

 

In the example ESD screen, a 

record relating to an enquirer 

has been retrieved and 

displayed. 
 

 

 

 

 

 

The fields displayed on the ESD 

screen are the default ‘out of the 

box’ fields provided by the 

software. 

 

Note that some fields are left 

blank (as they may be unused). 

 

To view additional details with 

regards to the current record (i.e. 

an Enquirer in this example), the 

use of the Other menu can be 

applied. 

 

In this example, the Other menu lists all the tables that are directly related to 

the current record.  

 

Note that methods to 

retrieve records will be 

outlined during a later 

section of the course. 
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As a further illustration of viewing 

information that is related to a record in 

the ESD table/screen, shown right is a 

screen displaying data relating to the 

calls made by an enquirer. 
 

This information is 

presented by selecting 

the Other menu and 

choosing Call Log. 
 

 

In the Enquiry Student Call (ESC) 

window (shown right), each call log 

will be listed. 
 

Note that a scrollbar will appear 

towards the right-hand side of the 

window to enable scrolling up/down.  
 

To return to the ESD table/screen, the 

current ESC window must been closed. 

 

 

 

As another example of viewing further 

information that is related to a record in 

the ESD table/screen, shown right is a 

screen displaying data relating to the 

actions undertaken for an enquirer. 

 

This information is 

presented by selecting 

the Other menu and 

choosing Actions. 
 

 

In the Enquiry Student Actions (ESA) 

window (shown right), each Area of 

Interest that the enquirer has enquired 

about will be shown. 
 

Note that a scrollbar will appear towards the right-hand side of the window to enable 

scrolling up/down.  
 

It should be noted that you cannot return to the ESD window until the current ESA window 

has been closed.  
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The examples presented above have been provided to illustrate how many tables/screens are 

already available in the SITS:Vision client server software in an ‘out of the box’ manner.  

Useful fields can be used where appropriate and any fields that are not required may be 

omitted. 
 

Menus can also be used to provide additional information via related tables (i.e. by the use of 

the Other menu and any available sub-menu commands).  The SITS:Vision client server 

software can also be used if the e:Vision portal is not available (i.e. if the e:Vision web-based 

service is temporarily offline). 

 

 

 

 

 

1.2.2 E:Vision example screens 
 

To compare the difference between SITS:Vision client server and e:Vision screens, the 

previous example of displaying and exploring data for an Enquirer will be presented below 

(using e:Vision screenshots instead of the client server screens). 

 

To display data with regards to an enquirer, in e:Vision 

you would firstly need to select the Search and Edit 

screen via the available menu. 

 

 

 

 

 

In first part of the 

Search and Edit 

screen, you could 

enter any desirable 

details with regards to 

the Enquirer that you 

are searching for (i.e. 

the family name of the 

Enquirer can be 

entered into the 

appropriate field as 

shown in the example 

displayed right). 

 

After entering suitable 

search criteria, select 

the Find button (or 

press the ENTER 

key). 

 

 

Note that methods to retrieve records and to navigate around client server screens will be 

outlined during a subsequent section of the course. 
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If more than one record 

exists for the specified 

person (i.e. an Enquirer 

in this example), a list 

of available records will 

be displayed. 
 

Select the desired record to display further details. 
 

In the View and Edit 

Enquirer Details screen 

(shown right), the record 

for the desired enquirer 

will be presented. 

 

Note that in e:Vision, 

only the required fields 

are displayed on the 

screen (in order to avoid 

cluttering the screen with 

non-required fields). 

 

Beneath the record data, 

further information with 

regards to the calls that 

the enquirer has made 

and any actions that have 

been completed will also 

be displayed. 

 

Note that the calls and 

actions areas show that 

this example enquirer 

has enquired on two 

occasions and that the 

most recent date has 

been recorded against 

each appropriate action. 
 

 

It should again be noted that e:Vision screens can be tailored to show only the required 

information from the SITS:Vision system.  The e:Vision screens are hosted via an online 

portal but not all aspects of the SITS:Vision client server can be replicated in e:Vision. 
 

The above examples have been presented to illustrate typical tables/screens in the 

SITS:Vision client server software and e:Vision.  The examples have also been provided to 

highlight the differences between the display of SITS:Vision client server and e:Vision 

screens. Subsequent sections of this course will further address the use and navigation of the 

client server screens. 
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1.3 Logging into SITS:Vision client server 
 

From the desktop (or the location/folder where shortcuts to SITS:Vision have been 

installed), double-click the SITS Vision icon. 

 

At the SITS:Vision log in screen (as 

shown right), enter your username and 

password. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Press the ENTER key or select the Ok button to continue. 

 

 

 

A welcome screen/message board 

will be displayed (an example is 

shown right). 

 

Press the ENTER key or select the 

Ok button to continue. 

 

 

 

 

 

 

 

 

 

 

 

 

Note that usernames will be 

configured in the format of 

AB000 (i.e. two characters 

followed by three digits). 
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After logging into SITS:Vision 

client server, the SITS Menu 

System will be displayed (an 

example is shown right). 
 

Note that the default view for 

SITS:Vision client server is to 

display the menu in a ‘Windows 

tree style’. 
 

Further details of the menu 

system will be outlined in a 

subsequent section of the 

course. 
 

 

1.4 Logging out of SITS:Vision client server 
 

There are several methods that can be used to exit and log out of 

SITS:Vision client server.   These methods are outlined below: 
 

(i) You can select the close icon to the upper right of the 

menu screen.  A dialog box will be displayed and you will 

be prompted with the message “Exit menu system?”. 
 

Select Yes to exit or No to remain logged in. 

 

(ii) You can also select the close 

icon from the upper right corner 

of the main background screen.   
 

A dialog box will be displayed and you will be 

prompted with the message “Do you want to 

leave this application?”. 
 

Select Yes to exit or No to remain logged in. 
 

(iii) Type EX in the option box (towards the upper left of the SITS 

Menu System screen).  Select Run or press the TAB or ENTER 

key (on the number pad) to execute the command and exit 

SITS:Vision client server.   
 

Note that no warning message will be displayed. 
 

(iv) Double click the Exit command located in 

SITS:Vision menu options.  
 

Note that no warning message will be displayed. 
 

(v) From the File menu, select Exit (or choose CTRL+Q as a 

keyboard shortcut). 
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1.5 Exercise 1A 
 

In this exercise you will load the SITS:Vision client server, log into the system and log out. 
 

1. Ensure that the computer is switched on and logged into a Windows session. 
 

2. From the desktop, double-click 

the SITS Training folder. 
 

Double click the SITS Vision 

Train icon. 
 

If a ‘security warning’ window is 

displayed, select the Run button. 
 

3. At the log in screen, enter your username 

and password (provided by the tutor). 
 

Press the ENTER key or select Ok. 
 

4. The welcome screen/message board 

will also be displayed.  Select the Ok 

button again to enter the SITS:Vision 

client server software. 
 

5. After logging into SITS:Vision client 

server, the SITS Menu System will be 

displayed (an example is shown 

right). 
 

Note that the default view for SITS:Vision client server is to display the menu in a 

‘Windows tree style’. 
 

6. You will now explore methods used to exit and log out of SITS:Vision client server.  

Choose any of the methods shown below: 
 

(i) Select the close icon to the upper right of the menu 

screen and answer Yes when prompted with the 

“Exit menu system?” dialog. 
or 

(ii) Select the close icon from the upper 

right corner of the main screen.   
 

Choose Yes when prompted with the dialog “Do 

you want to leave this application?”. 
or 

(iii) Type EX in the option box (towards the upper left of 

the SITS Menu System screen).  Select Run or press 

the TAB key or the ENTER key on the number pad to 

execute the command and exit SITS:Vision client server.   
 

7. If you finish the exercise quickly, repeat all the steps above and try an alternative 

method to exit the system (as outlined in step 6 above or section 1.4 in the manual). 
 

(End of Exercise) 
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Section 2 – Navigation 

 
In this section of the course, you will learn about: 

 

 

 Windows tree style menus. 

 

 

 Panel buttons. 

 

 

 Using commands to display tables/screens. 

 

 

 SITS:Vision client server screen components. 

 

 

 Further navigation and shortcuts: 

 

 

 Pull-down menus. 

 

 

 Right-click menus. 

 

 

 Keyboard shortcuts. 

 

 

 

 

 

 

 

 

There are two exercises in this section to help illustrate the above topics: 

 

 Exercise 2A: Exploring the use of menus, panel buttons and navigation techniques. 

 

 Exercise 2B: Exploring a range of menu and keyboard shortcut options. 
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2.0 Windows tree style menus and the panel buttons 
 

Although there are several menu 

formats available in the SITS:Vision 

client server, “Windows tree style” is 

preferred as it offers more 

functionality than other styles. 
 

To the right is an example of a 

“Windows tree style” view of the 

SITS:Vision main menu options. 
 

To the top of the window, panel 

buttons provide a range of useful 

facilities. 

 

 

 

 

 

After entering a command in the 

option box, the Run button will 

run/open a menu option (or the last 

menu option that was previously 

opened). 

 

The Search button provides access to a 

Keyword Search window where a 

menu search can be performed. 

 

Enter a word (or words) in the Search for box, select 

All words or Any word (if desired) and choose the 

Find button.  

 

A list of results will be displayed and the Run button 

can be used to run (open) a highlighted option. 

 

The Clear button will clear/empty the Keyword 

Search window. 

 

 

The expand all button will expand every branch of the menu tree and the 

collapse all button will collapse all branches. 

 

The Up button will move the user from a sub-menu back to the previous 

menu (i.e. the next menu higher in the tree). 

 

The Home button will move a user to the top of the menu tree. 

 

Option box     Run button 
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The History button will display the ‘history’ folder which will show the 

most recently accessed menu options within the current session. 

 

 

The Favourites button will display menu options that the user has added 

to their ‘favourites’ folder. 

 

 

The star button presents three options depending on the selected menu option: 
 

 A plus icon is displayed if a menu option can be added to “Favourites”. 
 

 A no-entry sign is displayed if a menu cannot be added to ‘Favourites’. 
 

 A cross is shown if a menu option can be removed from the ‘Favourites’ list. 

 

 

The View button can be used to change the format of the menu options.  By 

selecting the View button, the display of menu commands can be toggled 

between list format or icon and text. 

 

 

The icons displayed in the SITS:Vision client server indicate the type of menu option 

available: 

 

Menu Close 

 

Option History / recent options 

 

Process My favourite options 

 

Report Help 

 

User / Person Web Page 

 

 

 

Icon and text List format 
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2.1 Using commands to display tables/screens 
 

Each table/screen in SITS:Vision client server can be displayed by using commands instead 

of locating a menu in the “Windows tree view” and running/double-clicking the desired menu 

option.  This provides a very quick and useful method to users who may frequently access a 

range of menu options during their use of the system. 
 

In the option box you can enter 

a menu command and press the 

TAB key, the ENTER key (on 

the number pad) or select the 

Run button to quickly display a 

menu option. 
 

Applying a shortcut/command 

can help a user from having to 

find the menu option (i.e. the 

example screen displayed right 

shows that the ESD screen is 

located in the Admissions 

(MAS), Enquiry Process Menu, 

Enquirer Data folders). 

 

 

2.2 Exercise 2A 
 

In this exercise you will explore the use of menus, panel buttons and navigation techniques. 
 

1. Ensure that you are logged into SITS:Vision client server and from the panel button 

area, select the Home button (so that the SITS:Vision Menu Options is displayed). 

 

2. As an example of opening 

a menu option, select the 

[+] icon adjacent to 

Admissions (MAS). 
 

 Select the [+] icon adjacent 

to Enquiry Process Menu 

and choose the option 

labelled Enquirer Data. 

 

3. From the list of options available on the 

right-hand side of the screen, double-click 

the Enquirer Student Details icon. 

 

 In this example the Enquirer Student Details (ESD) window will be displayed.  For 

the moment we will not need to make use of this window (as it was just an example of 

opening a command/window in the SITS:Vision client server software). 
 

(Continued…) 
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4. Close the window (select the  icon 

towards the upper right corner of the 

window or press the F4 key).   
 

With the Enquirer Student Details icon still highlighted (as shown above), select the 

icon.  
 

5. When prompted with ‘add to favourites?’, select the 

Yes button. 
 

6. You will now open another example menu option using a command instead of 

locating the option in the “Windows tree style” view. 
 

 Although you are about to open a particular screen/table, do not worry about the 

contents of the screen for the moment as this is just an experiment to open a screen by 

using a command. 
 

 In the option box (upper left corner of the SITS Menu 

System window), enter the command TRAN (for the 

Transfer Options screen) and press the TAB key, the 

ENTER key (on the number pad) or select the Run button. 
 

7. Close the window (select the icon towards the upper right corner or press F4).   
 

With the Transfer Options icon still highlighted (as 

shown right), select the  icon. 

 

When prompted with ‘add to favourites?’, select the Yes 

button. 
 

8. View the ‘Favourites’ folder by selecting the button. 
 

9. You should be able to see the favourites that you 

have added so far.  Double click any of the 

favourites to display a screen (and exit the chosen 

screen afterwards as we will not be using the 

selected screen during this exercise). 
 

10. Back in the Favourites list, select any of the options that you have added so far and 

choose the button.   
 

When prompted to confirm the removal of the 

favourite, select the Yes button.  The chosen option 

will be removed from the favourite list.  
 

11. Repeat the step above to remove all favourites added to the Favourites list. 
 

 

12. (Optional) If you finish the exercise quickly, select the History button 

to re-open any screens that you may have previously viewed.  Also try 

the View button to change the display of the menu options. 
 

(End of Exercise) 
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2.3 SITS:Vision client server screen components 
 

There are four basic kinds of screens within the SITS:Vision client server software.  These 

screens are: 
 

 Data maintenance screens 

 Process screens 

 Report screens 

 SITS:Vision management screens 
 

A typical screen is usually composed as follows: 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

SITS:Vision will also make use of many windows controls (often referred to as ‘widgets’).  

Some examples of these types of controls are: 
 

 Command buttons 
 

 Pull-down/drop-down list  

The pull-down list, displays a list of options that you can choose 

from.  Select the down arrow to view all items in the list and move 

the mouse over the item to select it (an example is shown left). 
 

 Option buttons (often referred to as Radio Buttons). 
 

A group of buttons that present a range of choices to the user.  If you select an 

option, all other options are automatically deselected. 

 

 Checkboxes 
 

Checkboxes are a set of square boxes that you can select or deselect to turn options on or off.  

With regards to checkboxes, you can select more than one box at a time. 

Menu bar 

SITS:Vision application name 

Fields 

Panel 

Program name 

User, institution & date 

Component, menu & program 

Occurrence 

Boilerplate Text 

Message line 
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 Tabs 
 

Some windows contain too many elements to fit in a single area.  To partition the window 

into groups of commands, tabs are often used.  Tabs display headings along the top and you 

can select the options under each heading by clicking on the tab itself. 
 

 Spin Boxes 

Spin boxes are used to select values.  The user can click the up or down 

arrows to increase/decrease the value in the box.  Additionally, the user 

can enter the number in the box directly. 

 

 

 

2.4 Further navigation and shortcuts 
 

SITS:Vision provides a number of different methods to perform the same function via 

keyboard or mouse interaction.  Every user may have a personal preference with regards to 

which method to apply.  This section therefore outlines a range of techniques that can be used 

to navigate around the SITS:Vision client server software. 

 

2.4.1 Pull-down menus 
 

Pull-down menus are located at 

the top of the SITS:Vision client 

server window.   

 

It should be noted that the menu 

options may change, depending 

on the window that may be 

opened in the main screen. 

 

In the main SITS Menu System screen (as shown above), the pull-down menus will consist 

of File, Edit, Misc and Help.   

 

In many other windows, a 

different range of menu options 

will be displayed (for example 

File, Edit, Goto, Misc, Other, 

Current, All and Help). 

 

It should be noted that File, Edit, Misc and Help will be available in all screens. 

 

Commands via the pull-down menus can be accessed by: 
 

- Selecting a menu by using a mouse. 
 

- Pressing the menu bar key (F10) followed by the underlined letter of the desired menu 

(you can also use the arrow keys after pressing F10 to move along/down menus). 
 

- Pressing ALT and the underlined letter of the desired menu. 
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The common menus (for all windows in SITS:Vision client server) are shown below: 

 

 

 

 

 

 

 

 

 

 

 

File menu: 
 

Add Used to add a new record (which once defined, needs to be stored). 

Retrieve Used to retrieve an existing record based on none, one or many selection criteria. 

Store Stores a new record or an existing record that has been modified. 

Delete Removes a record.  You will be prompted to confirm the action. 

Release Prepares the retrieved record to be used as a template for a new record. 

Print Used to print a screen.  Note that this option is also available on the Misc menu. 

Export Allow data to be extracted from the system for manipulation with other software. 

Import Allows data to be imported from external sources. 

Link Start/Stop Provides the ability to start a Dynamic Data Exchange (DDE) link with another 

application.  The application can be automatically launched when the user starts 

a DDE link and closed when the user terminates the link. 

Accept Exits from a program/screen or zoom mode.  Accept also accepts a code from a 

selection list. 

Quit Quit from a program/screen or zoom mode.  Quit also exits a selection list 

without selecting a code. 
 

Edit menu: 
 

Cut, Copy, Paste Standard Windows cut/copy/paste commands. 

Clear Field Delete the entry in the field. 

Edit Field The ‘Edit Field’ option is available for any field that is greater than 50 characters 

(where the field is not part of the primary key). The text from the selected field 

will be taken through to the ‘Edit Field’ screen where it will be possible to 

perform Cut, Copy, Paste, Undo, Re-Do, Find, Find Next and Find and Replace. 

Zoom Increases the size of the working area (as a larger 

window).  Note that you must un-zoom using the 

button before you scan store a record. 

Quick Zoom Increases the size of the working area to a full screen 

window. 

Insert Wildcard Inserts a wildcard or Boolean operator into a field. 

Insert Special Inserts a special character. 

Get Text Inserts the contents of text file into the current field. 

Write Text Writes the contents of the current field into a text file. 

Panel on/off Turns the panel (just beneath the menus) on or off. 
 

 

 
 

 

 
 

Global update Allows a user to make a change to a field which can be applied to many records 

at once. 

Clear, retrieve, store, print, message buffer 

Add record, first, previous, next, last 

Cut, copy, paste, clear, zoom, help 
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Goto menu: 
 

Field Value Go to a value in a field on the record in the retrieved list. 

Rec Number Go to a specific record in the retrieved list. 

Next rec / Prev rec Go to the next or previous record in the retrieved list. 

First rec / Last rec Go to the first or last record in the retrieved list. 

Down / Up screen Go the record at the bottom or top of the screen.  This option is useful for a list of 

simpler records that have been retrieved. 

 

Misc menu: 
 

Clear screen Removes all the current details on the screen (but does not delete them). 

Print screen Triggers a process to print the screen. 

Message Accesses the message buffer.  The buffer may contain error, warning or 

information messages. 

Print Message Prints the contents of the message buffer. 

Quick Analysis Allows the user to run an analysis of the values in a specific field and/or perform 

cross analysis with another field (for example: minimum, maximum, total value, 

average, count etc). 

Sort Allows the user to perform a sort operation. 

Drop records Enables the user to drop or keep records from a retrieved list using a variety of 

criteria including ranges or values of records.  It should be noted that dropped 

records are not deleted; they are not available for viewing or processing on the 

current screen.  This facility is useful if you are amending a large list as you are 

able to drop records that have already been viewed or amended. 

Set ‘IO’ Level Options can be defined to specify the level to which messages are returned to the 

message buffer by the system. 

Save profiles Saving a profile enables a user to temporarily store information so that it can be 

reused when the screen is next accessed or as part of the retrieval of data. 

Load last profile Allows the user to load the last combination of values that they used to retrieve a 

certain set of records if “Save Profiles” had been enabled. 

My personal notes Allows the user to add information that is available for inclusion in a standard 

letter.  The note is created as a text file in the working directory on the user’s PC. 

 

Help menu: 
 

Help Displays the help window in relation to the currently opened window. 

SITS:Vision Manual Gives access to the SITS:Vision manual. 

Keyboard Help Displays a map of the keyboard with an explanation of the special keys. 

My SITS Web Site Gives access directly to the “My SITS” Website (www.mysits.com) 

e:Vision Login Gives access directly to e:Vision via the Internet. 

Server Info Provides server information. 

About Help with regards to the version of the field, program, its location, privileges 

and hot fixes. 
 

 

2.4.2 Right-click menus 
 

You are also able to right-click any of 

the SITS:Vision client server screens 

or fields.  A context/right-click menu 

will be displayed (and the contents 

will vary depending on where you 

right-clicked the mouse). 
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2.4.3 Keyboard shortcuts 
 

 The GOLD key 

 

The gold key can be used to provide additional functions when applied 

in conjunction with normal keys.  For example GOLD+Z would activate 

the zoom function.  In Windows, the GOLD key is the + key on the 

number pad (as shown in the keyboard help window below) 

 

Note that you can also press the ESC key to activate the ‘gold key’ function (which is useful 

for keyboards or laptops which may not provide a number pad).  For example, to apply the 

‘GOLD+Z’ keys for the zoom function you can either press + key on the number pad and Z 

or ESC and Z. 

 

 

 Function keys 

 

The F1 through to F12 keys can also be used as shortcut keys to popular commands: 

 

Key Action GOLD+key CTRL+key ALT+key 
F1 Help Help SITS:Vision manuals Keyboard 

F2 Detail Detail - - 

F3 Accept Accept - - 

F4 Quit Quit Quit Exit application 

F5 Retrieve - - - 

F6 Store - 
Switch window 

within session 
- 

F7 Clear field Clear field Clear field - 

F8 Previous field Previous field - - 

F9 Message Message Message - 

F10 Activate menu Activate menu - - 

F11 Print screen Print screen - - 

F12 Clear screen Clear screen Print screen - 

 

 

 ALT key 

 

The ALT key can also be used to access keyboard shortcuts with regards to 

menus and commands (in much the same manner as with many other 

Windows-based applications).   

 

Press the ALT key to highlight menu hot keys and then select another 

keystroke (note that you do not need to hold down the ALT key).  Keyboard 

shortcuts are displayed with an underscore (as demonstrated in the example 

menu shown right). 
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2.5 Exercise 2B 
 

In this exercise, you will explore a range of menu and keyboard shortcut options. 
 

1. Ensure that you are logged into the SITS:Vision client server 

software and from the panel button area, select the Home button (to 

make sure that the SITS:Vision Menu Options are displayed). 
 

2. You will now open a screen so that you can explore a number of keyboard shortcuts. 
 

 In the SITS Menu System 

screen, open the Enquirer 

Student Detail table/screen 

by entering ESD into the 

option box (and selecting the 

Run button or by pressing 

TAB or ENTER from the 

number pad). 
 

  You can also load the table/screen in the following menus: Admissions (MAS), 

Enquiry Process Menu, Enquirer Data. 
 

 Do not worry too much about the actual contents of the menu options explored during 

this exercise; example screens are used during the exploration of menus/keys etc. 
 

3. In the ESD table/screen, enter the 

Surname and Forename Used fields 

as shown right. 
 

 Note that you can either click into a field to enter the data or press the TAB key to 

move to the next field (or SHIFT+TAB to move back to a previous field). 
 

4. After entering the example data shown above (i.e. Nigel Danvers), 

select the File menu and choose Retrieve. 
 

 This action will open the record based on the values entered into 

the current table/screen.    
 

You can also choose CTRL+R or F5 as keyboard shortcuts to retrieve a record. 

 

 

 
 

5. The example record for ‘Nigel Danvers’ (a previous enquirer) will be loaded. 
 

6. As an example of using the ‘zoom function’, position 

the cursor in the Home Address field. 
 

Select the Edit menu and choose Zoom or select the zoom button from the panel 

to zoom into the Home Address field (the CTRL+Z shortcut can also be used). 
 

 Select the green tick icon or press F3 to accept the current address in the field. 
 

(Continued…)

Note that further record operations (Add, Store, Delete etc) will be explored in a subsequent 

section of the course.  This exercise briefly introduces the concept of ‘record retrieval’. 
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7. Back in the ESD (Enquirer Student Detail) table/screen, select the 

Other menu to list all of the tables that are directly related to the current 

record (i.e. an Enquirer in this example).  
 

8. As a further illustration of 

viewing information that is 

related to a record in the ESD 

table/screen, select Call Log 

from the Other menu. 
 

The Call Log option will display 

data relating to the calls made by 

an enquirer (as shown right in 

the Enquiry Student Call 

window). 
 

Note that a scrollbar will appear 

towards the right-hand side of the 

window to enable scrolling 

up/down (you can also use the 

Page Up/Page Down keys). 
 

To return to the ESD screen, 

close the current screen by 

selecting the [x] icon in the upper 

right corner or press F4. 
 

9. As another example of viewing 

information that is related to a 

record in the ESD table/screen, 

select the Other menu and 

choose Actions. 
 

The Actions option will display 

each Area of Interest that the 

enquirer has enquired about (as 

shown right in the Enquiry 

Student Actions window). 
 

Use the scrollbar towards the 

right-hand side of the window 

(or the Page Up/Page Down 

keys) to scroll up/down.  
 

To return to the ESD screen, close the Enquiry Student Actions screen (select the [x] 

icon in the upper right corner or press the F4 key). 
 

10. Close the ESD screen (select the [x] icon in the upper 

right corner of the window or press F4).  If asked if you 

wish to ‘Quit without saving/storing’, choose Yes as you 

will not be saving any changes in this exercise. 
 

(Enter of Exercise) 
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Section 3 – Record operations 

 
In this section of the course, you will learn about: 

 

 

 Retrieving records. 

 

 

 First, previous, next or last records. 

 

 

 Wildcards and Boolean operators. 

 

 

 Adding records. 

 

 

 Deleting records. 

 

 

 Releasing records. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are two exercises in this section to help illustrate the above topics: 

 

 Exercise 3A: Applying the use of wildcards and Boolean operators to retrieve data. 

 

 Exercise 3B Experimenting with the addition, deletion and releasing of records. 
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3.0 Retrieving records 
 

Towards the upper area of a data table/screen, a line 

indicating the number of the current record, the total 

number of records retrieved and the name of the table 

will be displayed.   
 

This information is known as the Current Occurrence of Total Occurrences. 
 

When initially entering a screen (and prior to retrieving 

records), “1 of 0 <Table Name>” will be displayed. 
 

 To retrieve a single record: 
 

- Use the primary key field(s), which will require a 

unique code. 
 

- Retrieve records using the File menu, choosing Retrieve. 
 

or  by pressing F5  
 

or  by pressing the TAB key. 
 

or  by pressing GOLD+R  (GOLD = the + 

key on the number pad or the ESC key). 
 

or  by right-clicking (just outside of the field 

box) and choosing Retrieve. 
 
 

 To retrieve multiple records: 
 

- In the desired field(s), enter suitable codes. 
 

- Retrieve the corresponding records (using File-> Retrieve, F5, GOLD+R or 

right-click->Retrieve as outlined above). 
 

- Scroll through the records using the record navigation buttons (see section 3.1 below). 
 

 

 

3.1 First, previous, next or last records 
 

To navigate to the first, previous, next or last record 

(in the currently opened window) you can use the 

panel buttons or keyboard shortcuts. 
 

 

First record: Select the button or use the keyboard shortcut of CTRL + 

PageUp (PgUp).  
 

Previous/next record: Select the buttons or use the keyboard shortcut of PageUp 

(PgUp) or PageDown (PgDn). 
 

Last record: Select the button or use the keyboard shortcut of CTRL + 

PageDown (PgDn) 

Add record, first, previous, next, last record 
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3.2 Wildcards and Boolean operators 
 

Wildcards and Boolean
2
 operators can be applied during the 

retrieval of records.  Wildcards can be inserted via the GOLD 

key or by using the Edit menu (selecting Insert Wildcard and 

choosing a suitable option). 

 

A wildcard can also be 

inserted by right-clicking a 

field and selecting Insert 

Wildcard (as shown right). 

 

 

 

The following table outlines the range of wildcards and Boolean operators that may be used. 
 

Character Type Definition 
.
* Wildcard Search for any characters.  For example, if you defined N.* in a primary 

key field, records whose code started with N would be retrieved. 
.
? Wildcard Can be used if the required records have a field of a specific length.  For 

example N.? .? .? 
would retrieve all records whose code started with N 

followed by three other characters. 
.
!
 Boolean NOT – for example 

.!COMP1 would retrieve all records that do not use 

the code COMP1. 
.
| 

.
; 

Boolean OR – allows two different search strings in the same field, where either 

one may be identified.  For example, N.* .| X.* would retrieve records 

whose code started with N or X. 
.
& Boolean AND – allows two different search strings in the same field, where both 

are identified.  For example C.* .& .!COMP1 would retrieve records 

whose code started with C and excluded any codes of ‘COMP1’. 
.
= Boolean Equal to – for example 

.=COMP1 would retrieve all records that match 

the code COMP1.  Entering 
.= on its own would retrieve all records 

where the field value is blank. 
.
!
.
= Boolean Not equal to – for example 

.!.=COMP1 would retrieve all records that 

do not match the code COMP1.  
.
> Boolean Greater than – for example 

.>C would retrieve all records greater than C 

(i.e. D, E, F … Z) 
.
>

.
= Boolean Greater than or equal to – for example 

.>.=C would retrieve all records 

greater than or equal to C (i.e. C … Z) 
.
< Boolean Less than – for example 

.<C would retrieve all records less than C (i.e. 

beginning with A or B). 
.
<

.
= Boolean Less than or equal to – for example 

.<.=C would retrieve all records less 

than or equal to C (i.e. beginning with A, B or C). 

 

 

 

 

                                                 
2
 Boolean algebra is based on logical counterparts, namely conjunction x∧y (AND), disjunction x∨y (OR) and 

complement or negation ¬x (NOT).  Further information with regards to Boolean algebra and operators can be 

found at http://en.wikipedia.org/wiki/Boolean_algebra_(logic)#Basic_operations. 

 

Note: leaving a blank in a search pattern will result in the retrieval of all records 

containing any value in the field (including blank entries).  Entering a GOLD asterisk 

(i.e. a 
.* character) will result with the retrieval of all records containing a value in the 

selected field (not including records where the chosen field contains a blank entry). 



University of London International Programmes   (Author: Dr. Richard M. Clark)   

SITS Training (Client Server)  Introduction to SITS:Vision Client Server 

University of London International Programmes 30 

 

3.3 Exercise 3A 
 

In this exercise, you will apply a range of different wildcards to retrieve records. 
 

1. Ensure that you are logged into the SITS:Vision client server 

software and from the panel button area, select the Home button (to 

make sure that the SITS:Vision Menu Options are displayed). 
 

2. You will now experiment with the use of wildcards and Boolean operators. 
 

 In the SITS Menu System 

screen, open the Enquirer 

Student Detail table/screen 

by entering ESD into the 

option box (and selecting the 

Run button or by pressing 

TAB or ENTER from the 

number pad). 
 

  You can also load the table/screen in the following menus: Admissions (MAS), 

Enquiry Process Menu, Enquirer Data. 
 

 Do not worry too much about the actual contents of the menu options explored during 

this exercise; example screens are used during the exploration of various tools. 
 

3. In the Surname field, enter the 

characters RUBE (as shown right). 
 

Add the wildcard 
.* by: 

 

- Selecting the Edit menu, choosing Insert Wildcard and Any characters (*) 
or 

- Right-clicking, selecting Insert Wildcard and choosing Any characters (*) 
or 

- Using the keyboard shortcut of GOLD + * (GOLD = number pad ‘+’ or ESC) 
 

4. Press F5 (or select File, Retrieve) to retrieve corresponding records.  If you are 

prompted with a ‘Retrieve Records?’ message, select Yes. 
 

5. A number of records will be loaded into the table/screen.  Note that the Occurrence 

label towards the top of the table/screen will indicate the number of matching records 

retrieved (an example is shown below). 

 

 

6. Scroll through the retrieved records using the 

record navigation buttons (towards the top of 

the screen) or the scrollbar or via keyboard 

shortcuts (Page Up, Page Down). 

 

 

 Display the record for Lucy Rubens (as 

shown right). 
 

(Continued…) 
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7. Press F12 or choose the Misc menu and select Clear Screen to 

clear the screen. 
 

8. You will now apply further wildcards to retrieve records. 
 

 In the Surname field, enter the characters 

DA (as shown right). 
 

After the DA text, insert the .? wildcard by: 
 

- Selecting the Edit menu, choosing Insert Wildcard and Any single character (?) 
or 

- Right-clicking, selecting Insert Wildcard and choosing Any single character (?) 
or 

- Using the keyboard shortcut of GOLD + ? (GOLD = number pad ‘+’ or ESC) 
 

This wildcard will retrieve any record with a surname consisting of 3 characters, 

starting with the characters DA and any other character. 
 

9. Press F5 (or select File, Retrieve) to retrieve corresponding records.  If you are 

prompted with a ‘Retrieve Records?’ message, select Yes. 
 

10. Scroll through the records (using the scrollbar, 

Page Up/Down or the record navigation buttons) to view 

the retrieved records.  
 

 Can you see how the wildcard has been successfully applied? 
 

 

11. (Optional extra example) Press F12 or choose the Misc menu and 

select Clear Screen to clear the screen. 
 

 In the Surname field, firstly enter the 

surname of DANVERS. 
 

 After ‘Danvers’, add the .| wildcard by: 
 

- Selecting the Edit menu, choosing Insert Wildcard and Or (  ) 
or 

- Right-clicking, selecting Insert Wildcard and choosing Or (  ) 
or 

- Using the keyboard shortcut of GOLD + | (GOLD = number pad ‘+’ or ESC) 
 

 After the .| wildcard, add the surname RUBENS (as shown in the above example). 
 

12. Press F5 (or select File, Retrieve) to retrieve corresponding records. 
 

13. The resulting records should include all enquirers with a surname of Danvers or 

Rubens. 
 

 

14. After experimenting with the examples presented in this exercise, close the 

Enquirer Student Detail window. 
 

(End of exercise) 
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3.4 Adding records 
 

New records can be added to a table at any time.  Records can be 

added using the File menu (by choosing Add) or by selecting the 

add record icon from the panel. 

 

 

When adding records, the following points should be considered: 
 

 A new record must have a unique code. 
 

 The code for a new record must follow any existing coding convention. 
 

 Code fields and short name fields will always default to UPPER CASE. 
 

 The format of the full name field (i.e. the description) can be entered in upper or 

lower case.  It is recommended that upper case is used for consistency and to help 

avoid mistakes during record retrieval. 
 

 Complete as many fields as possible in the new record. 
 

 Some fields may be mandatory and you will be unable to leave 

such fields blank. 
 

 After completing any required fields, store the record by 

pressing the F6 key or by choosing the File menu and selecting 

Store. 

 

 

 

3.5 Deleting records 
 

If you have appropriate user access rights to delete records you can delete by: 
 

- Retrieving the desired record in an appropriate screen (enter suitable criteria into a 

desired field and retrieve the record using the File->Retrieve menu or the F5 key). 
 

- With the correct record displayed on the screen, select 

the File menu and choose Delete. 
 

- In the Delete Confirmation window, select Yes to 

confirm the deletion or No to cancel. 
 

- Close/quit the screen (press F4 or select the close window icon). 

 

 

Note that you must delete any related table entries prior to deleting the 

parent table entry.  If you do not, you will leave the low level record 

‘hanging’. 

 

Also note that deleting a record in one table may affect records in another.  

It should also be noted that not all users will be able to delete records 

(depending on their user access rights). 
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3.6 Releasing records 
 

If there are many records that you wish to create (perhaps with very similar contents for each 

record), you can apply the use of the release facility to use a single record as a template.   

 

The release facility can be found by selecting the File menu and 

choosing Release. 

 

Using a single record as a template, you can make modifications and 

store the modified record.    

 

Note that the new record is created whilst leaving the old record intact.   

 

It should also be noted that the primary key must be changed before the new record can be 

stored. 

 

 The steps involved in releasing records are: 
 

- Retrieving the desired record in an appropriate screen (F5 or File->Retrieve). 

 

- From the File menu, select Release to release a new record. 

 

- The Current & Total Occurrence line will display 

‘1 of 0 records’ (an example is shown right). 

 

- Change appropriate values in the record (including the primary key). 

 

- Press F6 (or choose the File menu and select Store) to store the new record.  The 

Current & Total Occurrence line will show ‘1 of 1 records’. 

 

- Close/quit the screen (press F4 or select the close window icon) or 

repeat the above steps to enter another record. 
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3.7 Exercise 3B 
 

In this exercise, you will add, delete and release records in a table. 
  

1. Ensure that you are logged into SITS:Vision and from the panel button area, select the 

Home button (to make sure that the SITS:Vision Menu Options are displayed). 
 

 Do not worry too much about the actual contents of the menu options explored during 

this exercise; example screens are used during the exploration of various tools. 
 

2. In the SITS Menu System screen, 

display the Site / Building / Room 

window by either entering SIT into 

the option box (and select Run, press 

the TAB key or the ENTER key 

from the number pad) 

 

Alternatively, locate the table/screen 

in the following menus: Menu 

System (MENSYS), Institution Data 

Menu, Resources (as shown right). 
 

3. In the example table/screen used during this exercise, you can create/view/edit records 

with regards to Site/Building/Room data.  For this example, enter data in the manner 

outlined below and press TAB to move to the next field. 
 

 In the Code field, enter a code of TEST0n where n is your computer number (i.e. 

TEST01, TEST02 etc – ask the tutor for assistance if required). 

 

  
 

 Press the TAB key to move to the Short Name field and enter the same data as the 

Code field (i.e. TEST01, TEST02 etc). 
 

In the Name field, enter a full name in the format of Test Site n where n is your 

computer number (i.e. 1, 2 etc – ask the tutor for assistance if required). 
 

 In the Name field, enter a full name in the format of Test Site n where n is your 

computer number (i.e. 1, 2 etc – ask the tutor for assistance if required). 
  

 

 
 

 To store the new record, press the F6 key, use the keyboard shortcut of CTRL+S or 

select the File menu and choose Store. 
 

4. The Enter Audit Description window will be 

displayed.  Enter a suitable Reason For 

Change (an example is shown right) and select 

the Ok button. 
 

5. To exit the screen, press F4 or select the [x] icon in the upper right corner. 
 

(Continued…) 

Note that after entering data into the Name field, if you press 

the TAB key once more, a message will be displayed asking 

“Add another record”?   If this message is presented, select No 

(as you will not be adding further records at this point). 
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6. You will now use the Release facility to create a new record based on the values 

already contained in an existing record. 
 

In the SITS Menu System screen, display the Site/Building/Room window by either 

entering SIT into the option box (and selecting Run, pressing TAB or ENTER from 

the number pad) or by locating the screen in the following menus: Menu System 

(MENSYS), Institution Data Menu, Resources. 
 

Enter the code that you applied during step 3 

(i.e. TEST01, TEST02 etc) and press the 

TAB key or F5 key to retrieve the record.   
 

Alternatively, you can double-click the empty Code field to display a selection list 

where you can choose the value that you entered during step 3 (remember to press the 

TAB key or the F5 key to retrieve the record after choosing from a selection list). 
 

7. The record that you created earlier will be reloaded into the 

current table/screen.  Select the File menu and choose Release. 
 

You can now modify the record with the knowledge that the 

original record will remain unchanged (i.e. you have copied a 

‘template’ of the original data to save as another record). 
 

Modify the fields with additional 

characters such as your initials or name 

(an example is shown right). 
 

 To store the new record, press the F6 key, use the keyboard shortcut of CTRL+S or 

select the File menu and choose Store. 
 

8. The Enter Audit Description window will be 

displayed.  Enter a suitable Reason For Change 

(an example is shown right) and select Ok button. 
 

Close the Site/Building/Room window. 
 

9. You will now delete the record that you have entered (as another example of using 

menus or keyboard shortcuts). 
 

In the SITS Menu System screen, display the Site/Building/Room window by either 

entering SIT into the option box (and selecting Run, pressing TAB or ENTER from 

the number pad) or by locating the screen in the following menus: Menu System 

(MENSYS), Institution Data Menu, Resources. 
 

Enter any of the codes that you applied 

earlier (during step 3 and/or step 7) and 

press the TAB key or F5 key to retrieve 

the record(s).   
 

 To delete the record(s), select the File 

menu and choose Delete. 
 

 You will be prompted to confirm the deletion of a record.  In the Delete 

Confirmation window, select the Yes button. 
 

 

(End of Exercise) 
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Section 4 – Tools & Special Characters 

 
In this section of the course, you will learn about: 

 

 

 Special characters. 

 

 

 GoTo field contents. 

 

 

 First, previous, next or last records. 

 

 

 Sorting. 

 

 

 Dropping records. 

 

 

 Quick analysis. 

 

 

 Exporting quick analysis data. 

 

 

 Cross referencing analysis. 

 

 

 Exporting Cross referencing analysis data. 

 

 

 

 

 

 

There are two exercises in this section to help illustrate the above topics: 

 

 Exercise 4A: Applying the use of special characters, using the GoTo field contents 

tool, sorting records, dropping records and making use of record 

navigation tools.  

 

 Exercise 4B: Exploring the quick analysis and cross referencing analysis tools. 
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4.0 Special characters 
 

There may be instances where you wish to quickly insert special characters into various fields 

in the SITS:Vision client server software.  To insert a special character, you can type a 

keyboard shortcut (if the required characters are available on the keyboard) or you can make 

use of the Insert Special menu command. 

 

 To enter keyboard characters: 
 

- Select the desired field (in a suitable window). 
 

- Type any desired characters (for example: if you required the name ANDRÉ, you 

would start by typing ‘ANDR’). 
 

- Press the GOLD key (+ on the number pad or the ESC key). 
 

- Press the J key and enter suitable special characters (for example: to complete the 

name ANDRÉ, you would then type E and ´ to insert the character É) 

 

 

 

 

 

 To enter special characters via the menu: 
 

- Select the desired field (in a suitable window). 
 

- Type any desired characters (for example: if you required the 

name ANDRÉ, you would start by typing ‘ANDR’). 
 

- From the Edit menu, select Insert Special. 
 

- The Insert Special Characters window will be displayed. 
 

- Position the cursor into the text box towards the lower edge of the 

window. 
 

- Choose an appropriate 

character to insert. 
 

- The character will be 

added to any existing text 

in the lower pane of the 

window. 
 

- To accept the changes 

made, select the green 

tick icon (or choose the 

red cross icon to cancel). 

 

 

 

 

Note: the shorthand notation for the above example would be: 

 ANDR <GOLD> J E ´ 
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4.1 GoTo field contents 
 

The GoTo Field Contents window can be used to quickly find a record according to 

specified search criteria.  This facility is very useful if you have retrieved many records 

(possibly hundreds of records) but then wish to search the retrieved records for particular data 

items. 
 

Before applying the GoTo Field Contents window, place the cursor into a suitable field in a 

record/window. 
 

From the GoTo menu, select Field Value and the GoTo Field Contents window will be 

displayed (note that at least one record may need to be retrieved/opened in order to activate 

the commands under the GoTo menu). 

 

 

 

 

 

 

 

 

 

 

The current field name will be displayed in the Field name box. 

 

In the Search for box, enter 

suitable text (an example is 

shown right). 

 

To search for the desired item, 

select the Find Forward or 

Find Backward buttons. 

 

 

 
 

If a corresponding record is found, the record data will be displayed. 

 

If you choose the Count button, the system will count the number of matching 

records (in the current window).  The count value will be displayed in the 

message bar, along the lower left edge of the screen. 

 

 

 

 

Repeat the above steps as required to display further results. 
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4.2 Sorting 
 

Towards the top of many windows, the number 

of records will be indicated as records 1 of N (in 

a similar manner to the example shown right). 
 

Rather than browsing randomly through the records until you find the record that you are 

searching for, you can sort the records into ascending or descending order. 
 

To apply the use 

of the sort tool, 

select the desired 

field and from 

the Misc menu, 

choose Sort. 

 

 

 

 

 

In the Sort window, you can choose 

up to three fields (as the levels for 

sorting) and further apply the option of 

Ascending or Descending for each 

field. 
 

To choose a field, select a drop-down 

arrow and choose a suitable option. 
 

Select the Ok button to apply the sort 

or select Cancel to abort. 
 

 

4.3 Dropping records 
 

Under the Misc menu, you can select Drop records if you wish to remove 

records (temporarily) from the currently displayed window.  Dropped 

records are not deleted, only temporarily removed from the current screen. 
 

This feature is useful if you wish to omit records from the current activity. 

 

In the Drop/Keep occurrences window, select the 

Drop records option and choose: 
 

 Current record (to drop the currently 

displayed record only). 
 

 Range of records (to delete a range of records 

from x to y) 
 

 Select by Value to indicate records that may 

be ‘dropped’ according to specified criteria.  
 

Select the Ok button when complete. 
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4.4 Exercise 4A 
 

In this exercise, you will apply the use of special characters, use the GoTo field contents tool, 

apply sorting, drop records and make use of record navigation tools. 
 

1. Ensure that you are logged into SITS:Vision and from the panel button area, select the 

Home button (to make sure that the SITS:Vision Menu Options are displayed). 
 

2. You will now experiment with the use of special characters. 
 

 In the SITS Menu System 

screen, open the Enquirer 

Student Detail table/screen 

by entering ESD into the 

option box (and selecting the 

Run button or by pressing 

TAB or ENTER from the 

number pad). 
 

  You can also load the table/screen in the following menus: Admissions (MAS), 

Enquiry Process Menu, Enquirer Data. 
 

 Do not worry too much about the actual contents of the menu options explored during 

this exercise; example screens are used during the exploration of various tools. 
 

3. In the Forename Used field, type:  ANDR 
 

From the Edit menu, select Insert Special. 

 

 In the Insert Special Characters window, check that the cursor is 

positioned after the text ‘ANDR’ towards the lower left corner of the 

screen.     
 

Select the button and note the insertion of the special character.  
 

To accept the text, select the green tick icon. 
 

 

 

 

 

 

 

 

 

 

 

This text ANDRÉ should now be displayed in the Forename Used box. 
 

4. Press F5 (or select File, Retrieve) to retrieve corresponding records.  If you are 

prompted with a ‘Retrieve Records?’ message, select Yes. 
 

5. Scroll through the records (using the scrollbar, Page Up/Down 

or the record navigation buttons) to view the surname for the 

retrieved records.  
 

6. After browsing the records retrieved so far, clear the current screen 

by selecting the Misc menu and choosing the Clear screen command 

(note that you can also press the F12 key to clear a screen). 
 

(Continued…) 

 

As an alternative approach, you can also use the keyboard to enter special characters: 
 

- Press the GOLD key (+ on the number pad or the ESC key) and press the J key. 

- Type: E and ´    
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7. With the Enquirer Student Detail 

table/screen still open, position the cursor in 

the Surname field and type the text: SMITH 
 

8. Press the F5 key (or from the File menu, select Retrieve) to 

retrieve records with a surname of ‘SMITH’. 
 

9. If you are prompted with the Retrieve confirmation message, 

select the Yes button. 
 

10. Now position the cursor in the Forename Used box (as you 

will search the retrieved records for a particular ‘forename’). 
 

11. From the GoTo menu, select Field 

Value and the GoTo Field Contents 

window will be displayed. 
 

12. In the Search for box, enter the text 

DAVID and select the Find Forward 

button. 
 

13. The appropriate record will be displayed in the Enquirer Student Detail window.  

This example demonstrates how you can ‘go to’ a particular instance of a record 

without manually scrolling through all records. 
 

14. Repeat steps 11 and 12 (above) a few more times to view additional records matching 

the name ‘David Smith’. 
 

15. After browsing the records retrieved so far, clear the current screen 

by selecting the Misc menu and choosing the Clear screen command 

(note that you can also press the F12 key to clear a screen). 
 

16. In the Surname field, enter the 

characters DAN (as shown right). 
 

After the characters DAN, add the 

wildcard .* by: 
 

- Selecting the Edit menu, choosing Insert Wildcard and Any characters (*) 
or 

- Right-clicking, selecting Insert Wildcard and choosing Any characters (*) 
or 

- Using the keyboard shortcut of GOLD + * (GOLD = number pad ‘+’ or ESC) 
 

17. Press the F5 key (or from the File menu, select Retrieve) to 

retrieve the records.   
 

If you are prompted with a Retrieve confirmation window, select the Yes button. 
 

18. Scroll through the records (using the scrollbar, Page Up/Down 

or the record navigation buttons) to view the retrieved records.  
 

Note how the default order of the records is via the Enquirer (ESD) Code field. 
 

(Continued…) 
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19. Position the cursor in the Surname field and from the Misc menu, choose Sort. 
 

20. In the Sort window, the Sort by field 

will already be populated. 
 

In the Then by field, select the 

drop-down arrow and choose: 
 

ESD_FUSD.ESD – Forename used 
 

Check that the Ascending option is 

selected for both fields. 
 

Select the Ok button and note how the records will be sorted in the order of 

Surname code and Forename used (in Ascending order). 
 

If you finish the exercise quickly, try the additional steps below or go to step 23. 
 

 

21. (Optional) Use the record navigation icons to scroll through the 

records and display any record of your choice.  Take note of the 

data shown and the record number.  
 

22. (Optional) From the Misc menu, select Drop records to remove desired record(s) 

from the currently displayed window.  Note that dropped records are not deleted (they 

are temporarily removed from the current screen). 
 

In the Drop/Keep occurrences 

window, select Drop records and 

choose the Current record option. 
 

Select Ok when complete. 
 

Notice how the chosen record has been 

removed from the screen. 
 

Experiment with further ‘drop records’ 

features (i.e. using the ‘Range of 

records’ options for example). 

 

 

23. Close the currently opened table/screen (by selecting the [x] icon from 

the top right-hand corner of the window). 
 

If you are prompted with a Quit confirmation window (as 

shown right), select the Yes button to quit the screen without 

saving any changes. 
 

Finally, from the panel buttons, choose the collapse all icon to close all current 

expanded menus/trees. 
 

 

 
 

(End of Exercise) 
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4.5 Quick analysis 
 

The Quick Analysis tool allows the user to perform basic 

mathematical analysis of the values in a field.   
 

To activate the Quick Analysis tool, select the Misc menu and choose 

Quick Analysis. It should however be noted that the Quick Analysis 

tool is only available if more than one record is retrieved in the 

current table. 
 

The basic mathematical analyses that can be performed are: 
 

o Minimum value in the field. 

o Maximum value in the field. 

o Total value of the fields. 

o Average of the values in the field. 

o Median (middle) value. 

o Mode (most common) value. 

o Standard deviation value. 

o Mode frequency. 

o A list of the values and a count of each type of value in both actual and percentage 

values. 

 

In the Advanced Quick Analysis 

window, the Field box will be populated 

with the code of the field where the 

cursor is currently situated. 
 

To apply mathematical analysis, ensure 

that the Mathematical analysis option 

has been selected. 
 

Select the Discard retrieved records 

after processing tick box if you wish to 

drop retrieved records after the use of the 

Quick Analysis tool (i.e. the previous 

window will be cleared after using Quick 

Analysis). 

 

Select the Group values case sensitively tick box if you wish to distinguish between 

lowercase and uppercase values in the analysed records. 
 

Select the Ok button to apply the Quick 

Analysis tool or Cancel to abort. 
 

It should be noted that the analysis may take 

a few minutes to process if you are 

processing a large number of records.  

During this time period, you may see a 

processing window displayed (as shown 

right). 
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If you wish to select a different format, select the Data format field and press 

F2 to display a list of available options (see Appendix A). 

 

After selecting Ok, the Quick Analysis 

Results window will display appropriate 

results (an example is shown right). 

 

 

In the results area of the window, you 

can also select the headers (Value, 

Count, Perc etc) to toggle the data 

between ascending and descending 

order. 
 

The message bar (lower left corner of 

the screen) will also display an 

indication of ascending or descending 

sorting if a header has been selected. 

 

 

Select the Ok button to close the window (or choose the Export button to export the data to 

an external file – as outlined in section 4.5.1 below). 
 

 

 

4.5.1 Exporting quick analysis data 
 

Note that in the Quick Analysis Results window (as shown above) you can 

also select Export if you wish to export the results to an external file. 
 

A Quick Analysis – Data export window will be displayed (as shown below).   

 

In the Data format field, you can change the format of the file by entering a suitable value 

(for example, CSV or EXCEL can be applied to create a comma separated value file that can 

easily be imported into Microsoft Excel).   

Adjacent to the Filename field, you can select the folder icon to choose an appropriate 

drive/folder.  Note that you are also able to edit the auto-generated filename if desired. 

 

Select the Ok button to export the data or Cancel to abort. 
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4.6 Cross referencing analysis 
 

A cross reference analysis allows the user to produce a cross 

tabulation, showing all the values held in two fields. The Cross 

referencing tool is available via the Advanced Quick Analysis 

window (as explored during the previous section of the course). 
 

To access the Cross referencing tool, select the Misc menu and 

choose Quick Analysis.  It should however be noted that the 

Quick Analysis command is only available if more than one record is 

retrieved in the current table. 
 

In the Advanced Quick Analysis 

window, select the option labelled 

Cross reference analysis. 
 

The Field 1 box will be populated with 

the code of the field where the cursor is 

currently situated. 
 

Select the Field 2 box and either press 

F2 or double-click to select a suitable 

field from the Select… window.  

 

 

 
 

 

In the Select… window, choose an appropriate field code to insert into Field 2. 

 

Scroll up/down using the vertical 

scroll bar (or use the Page Up / 

Page Down keys). 

 

When you have identified the 

desired field, select the field and 

press F3 to accept or choose Accept 

from the File menu (you can also 

choose the keyboard shortcut of 

CTRL+A or double-click an item 

from the list). 

 

 

 

 

 

 

 

The F2 key is used to 

view/select further details. 
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Select the Discard retrieved records 

after processing tick box if you wish 

to drop retrieved records after the use 

of the Quick Analysis tool (i.e. the 

previous window will be cleared after 

using Quick Analysis). 

 

Select the Group values case 

sensitively tick box if you wish to 

distinguish between lowercase and 

uppercase values in the analysed 

records. 

 

Select the Ok button to apply the 

Cross reference analysis tool or 

Cancel to abort. 

 

It should be noted that the analysis may take a 

few minutes to process if you are processing a 

large number of records.  During this time period, 

a processing window may be displayed (as 

shown right). 

 

 

 

The Quick Analysis – 

Results window will 

display the results of the 

Cross reference analysis. 

 

Note that the default format 

is set to Text. 

 

 

The example displayed 

right presents a cross 

reference analysis of the 

number of enquiries by 

date and method of contact. 
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To change the display 

format to HTML, select 

the Html radio button. 

 

 

 

 

 

The example displayed 

right presents a cross 

reference analysis of the 

number of enquiries by 

date and method of contact. 

 

 

 

 

 

 

 

 

 

 

 

To change the display to 

Chart format, select the 

Chart radio button. 

 

 

 

 

 

The example displayed 

right presents a cross 

reference analysis of the 

number of enquiries by 

date and method of 

contact. 

 

 

 

 

 
 

In Chart format, you can change the type of chart by selecting a 

suitable option under the Display Mode group (towards the 

top-middle area of the Quick Analysis – Results window). 

 

 



University of London International Programmes   (Author: Dr. Richard M. Clark)   

SITS Training (Client Server)  Introduction to SITS:Vision Client Server 

University of London International Programmes 49 

 

If you wish to select a different format, 

select the Data format field and press F2 

to display a list of available options (see 

Appendix A). 

 

4.6.1 Exporting cross referencing analysis data 
 

As outlined earlier in section 4.5.1, you can also choose the Export button in 

the Quick Analysis – Results window if you wish to export the results to an 

external file. 

 

In the Quick Analysis – Data export window, 

enter a suitable format in the Data format field 

(for example, CSV or EXCEL can be applied to 

create a comma separated value file that can 

easily be imported into Microsoft Excel). 

 

Adjacent to the Filename field, you can select the folder icon to choose an appropriate 

drive/folder.  Note that you are also able to edit the auto-generated filename if desired. 

 

Select the Ok button to export the data or Cancel to abort. 
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4.7 Exercise 4B 
 

In this exercise, you will explore the quick analysis and cross referencing analysis tools. 
 

1. Ensure that you are logged into SITS:Vision client server and from the panel button 

area, select the Home button (to make sure that the SITS:Vision Menu Options are 

displayed). 
 

2. You will use wildcards (as explored earlier during section 3.2) and the 

Quick Analysis tool to view the number of enquiries during a period of time. 
 

 In the SITS Menu System 

screen, open the Enquirer 

Student Detail table/screen 

by entering ESD into the 

option box (and selecting the 

Run button or by pressing 

TAB or ENTER from the 

number pad). 
 

  You can also load the table/screen in the following menus: Admissions (MAS), 

Enquiry Process Menu, Enquirer Data. 
 

3. Position the cursor in the Last Call Date field. 
 

In the Last Call Date field, enter the date range 

shown below (including wildcards): 
 

- Press the GOLD key (ESC or + on the number pad) and type > 

- Press the GOLD key (ESC or + on the number pad) and type = 

- Type: 01/11/2009 

- Type: & 

- Press the GOLD key (ESC or + on the number pad) and type < 

- Press the GOLD key (ESC or + on the number pad) and type = 

- Type: 30/11/2009 
 

The text will appear as: ·>·=01/11/2009&·<·=30/11/2009 
 

 

  
 

 
 

 

4. Press the F5 key (or from the File menu, 

select Retrieve) to retrieve records.   
 

When prompted to retrieve files, select Yes. 
 

5. Position the cursor in the Last Call Date 

field and from the Misc menu, choose the 

Quick Analysis option. 
 

In the Advanced Quick Analysis window, 

check that Mathematical analysis is 

selected and select the Ok button. 
 

(Continued…) 

Note that you can also right-click in the field (or use the Edit menu) and choose 

Insert Wildcard to choose the >, = or < characters instead of typing them.  Ask 

the tutor for assistance if required.  
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6. In the Quick Analysis Results window, a 

table will be shown (in a similar manner 

to the example shown right). 
 

7. Select the headings Value, Count and 

Perc to modify the view of the data in 

ascending/descending order. 
 

 

 

8. Close the Quick Analysis Results 

window to return to the Full Student 

Details window. 
 

9. Back in the Enquirer Student Detail table/screen you should still have the records 

opened during the earlier part of this exercise (if not, repeat steps 2-4 or call the tutor 

for assistance).  
 

10. Position the cursor in the Last Call Date field and from the Misc 

menu, choose the Quick Analysis option. 
 

11. In the Advanced Quick Analysis – Selection 

screen, check that the option Cross reference 

analysis has been selected. 
 

12. Field 2 will be displayed in the window.  

Select Field 2 and press F2 (or double click 

Field 2) to view a list of field names available 

for analysis.   
 

13. Use the Page Down key or the vertical scroll 

bar to scroll through the records until you get 

to the “ESD_MOCC – Method of Contact” 

field.   
 

With this field code selected, press the F3 key, 

double-click the field code or choose the File 

menu and select Accept. 
 

14. Back in the Advanced Quick Analysis 

window, select the Ok button to continue.  

Note that there may be a brief delay whilst the 

results are calculated & displayed. 
 

15. In the Quick Analysis – Results screen, a 

table of the results will be displayed.   
 

Towards the upper left corner of the screen, select Text, Html 

and Chart from the Format box to view different 

representations of the data.   
 

Close the Quick Analysis – Results and ESD windows when complete.  
 

(End of exercise) 
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Appendix A – Further exported data formats 
 

Further exported data formats are available when applying the Data export feature during the 

use of the Quick Analysis or Cross referencing analysis tools. 

 

In the Data export window, clear the 

Data format field and either double click 

the field or press the F2 key to display a 

selection list. 

 

 

 

 

 

 

 

The contents of the selection lists are shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

From the selection list, you can either double click a suitable option or highlight a value and 

press F3. 
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Appendix B – Glossary 
 

The following terms, abbreviations and commands have been used during the topics 

presented throughout this course/manual.  The table below provides a summary of the terms 

used. 
 

Term Description 

BAR Bar delimited file.  A ‘bar’ character is used to separate different 

items of data. 

Boolean operators Boolean operations allow you to combine search terms using the 

Boolean operators AND, OR and NOT. 

Cross referencing analysis A cross reference analysis allows the user to produce a cross 

tabulation, showing all the values held in two fields. 

CSV Comma separated value file.  A ‘comma’ character is used to separate 

different items/fields of data. 

e:Vision Provides secure portal access via the web and is used to manage the 

delivery of data and information from the SITS:Vision client server  

system. 

ESA Enquirer Student Actions table.  Each ESD (Enquirer Student 

Details) table may also have one or more ESA records associated 

with it.  An ESA record is created for each programme (Area of 

Interest) that each enquirer requests information about. 

ESC Enquirer Student Call table.  Each ESD (Enquirer Student Details) 

table may also have one or more ESC records associated with it.  An 

ESC record is created for each contact that an enquirer has had with 

the University. 

ESD Enquirer Student Details table.  This table holds one record per 

enquirer (contact information and most recent contact with the 

University). 

EX The Exit command 

Favourites Panel button used to display menu options that the user had added to 

the ‘favourites’ folder. 

Field A field is the basic unit of data (i.e. a single piece of information) in a 

record.   

GOLD key The GOLD key is the + key on the number pad or the ESC key. 

GoTo field contents The GoTo Field Contents window can be used to quickly find a 

record according to specified search criteria. 

History Panel button used to display the ‘history’ folder which will show the 

most recently accessed menu options within the current session. 

Home Panel button used to move the user to the top of the menu tree. 

Message buffer Displays any error messages and the output of some processing 

operations.  The contents of the message buffer can be viewed and 

printed.   

Panel buttons Towards the top of the SITS:Vision main menu, a range of buttons 

are displayed.  These buttons are referred to as panel buttons. 

 

 

Primary key A unique identifier for each records (usually the first fields in a 

table). A primary key cannot be duplicated (in another record) and 

cannot be edited. 
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Term Description 

Quick Analysis The Quick Analysis tool allows the user to perform basic 

mathematical analysis of the values in a field. 

Record A record stores information with regards to a person/item etc. Each 

record can be uniquely identified via a primary key. 

SIT The Site/Building/Room screen. 

SITS Menu System The menu system is displayed in a ‘Windows tree style’ format and 

provides access to options/screens that the user is permitted to run. 

SITS:Vision SITS:Vision is a management information system used by many 

Higher Education institutions across the UK.   

SITS:Vision client server SITS:Vision client server provides a ‘back end’ to the system and is 

useful for infrequent tasks.  The screens in SITS:Vision cannot be 

modified.  Not all of the fields in each table/screen need to be 

necessarily used as only the desired fields may be utilised as required 

Table Also referred to as an ‘entity’, a table is a group of data consisting of 

records. For example, information about a student would be stored in 

a ‘student’ table. 

View The View button can be used to change the format of the menu 

options.  By selecting the View button, the display of menu 

commands can be toggled between icon and text or list format. 

Wildcard A wildcard character is a character that may be substituted for any of 

a defined subset of all possible characters.  Wildcards are used during 

searches, for defining criteria and for the retrieval of records  
 

A wildcard character (for example, *) can therefore be applied to 

identify data/records according to the specified characters.  For 

example, to search for all records starting with ‘R’, you would enter 

‘R*’ or to search for an address with ‘Russell’ in the data you could 

enter *russell* in an address field. 

Windows Tree Style Menus The “Windows tree style” is the preferred menu format in 

SITS:Vision as it offers more functionality than other styles.  A ‘tree’ 

displays the options/commands available to the user and branches of 

the tree can be expanded and collapsed by selecting the [+] and [-] 

icons respectively. 
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Summary 
 

 

During this course, you have been introduced to the 

SITS:Vision client server software for the viewing, creation 

and editing of database records. 

 

Upon completion of this course, you should now have a basic understanding of the following 

topics: 

 

 Introduction to SITS:Vision. 

 Differences between SITS:Vision client server and e:Vision. 

 Examples of client server and e:Vision screens. 

o Client server example screens. 

o E:Vision example screens. 

 Logging into SITS:Vision client server. 

 Logging out of SITS:Vision client server. 

 Windows tree style menus and the panel buttons. 

 Using commands to display tables/screens. 

 SITS:Vision client server screen components. 

 Further navigation and shortcuts. 

o Pull-down menus. 

o Right-click menus. 

o Keyboard shortcuts. 

 Record operations: 

o Retrieving records. 

o Using first, previous, next or last record navigation icons. 

o Wildcards and Boolean operators. 

o Adding records. 

o Deleting records. 

o Releasing records. 

 Tools: 

o Special characters. 

o GoTo field contents. 

o Sorting. 

o Dropping records. 

o Quick analysis. 

 Exporting quick analysis data. 

o Cross referencing analysis. 

 Exporting cross referencing analysis data. 

 


